sending emails fails

Hi there,

after months of using IN self hosted without any problem, it suddenly stopped sending mails. I tried to debug as far as I could - to no avail. Here’s what I tried:

1. Send Mails via mail() (used before)
Test mail sending stucks at “Working…” message. I get nothing in Postfix/PHP/Apache error logs. Can’t tell if mail() is even called. Laravell-error.log is also not logging anything. Enabled debug mode which gives me “production.INFO: Sending email - To: my@email | Reply: my@email | From: my@email [] []” (removed my actual email address) - but it doesn’t send anything…

2. Send Mails via SMTP
First try using host “localhost” fails because the certificate name of my server doesn’t match “localhost”, of course. Second try using my server’s domain name ends in a timeout message: “Connection could not be established with host [Connection timed out #110]”.

I think there is no problem with the email server as all other emails are processed sucesfully. Mails are being submitted via SMTP and PHP’s mail() successfully. What makes me wonder is why the SMTP connection obviously can be established using “localhost” (failing afterwards due to TLS certificate error but leaving a trace in Postfix’ logs) but fails when using the domain name (no logs).

Any hints would be appreciated.


IN Version: 4.5.17 (updated through the update shell script)

Did anything change when it stopped working?

I don’t think so. I can’t remember when exactly I upgraded IN to 4.5.17 - possibly this was the last change.

Checked the date of the IN files and I am now quite sure that IN stopped sending mails right after I upgraded to 4.5.17.

In that case you may want to see if downgrading to 4.5.16 fixes it

Assuming that was the version you upgraded from…

Reverted back to 4.5.14 (you all have backups, right? ;-)) emails are now being send again. Looks like there is a bug in 4.5.17.

Thanks, that’s helpful to know.

We’ll look into it…