Sender name wrong using gmail

I entered my company name in the settings inside Invoice Ninja, but when I send invoices, they get sent out by the name on the gmail account (my name). How can I get the Invoice Ninja settings to override that and send from my company name?


I’m not sure if it’s supported.

@david can you please advise?

in past versions there was an option to configure smtp … but now I don’t see it

the mail will be configured in your .env file

This is the hosted version, not the self-hosted.


This may be a limitation within GMail itself, looking at the code, we do pass through the updated values, but they are probably being ignored by Google.

Understood. In that case, I’ll try changing the name in gmail.