Self Hosted. navigating to ...index.php does not return the login page

After many attempts to self install, I eventually used xampp and i12bretro example from youtube ( This installed correctly, with one small change by adding the php_ prefix to the extension mysqli.

The user and database was also created successfully, and the tables are fully created in the DB.

However navigating to http://localhost/invoiceninja/index.php does nothing. The cursor goes round and round and nothing happens… for minutes on end…and no login page is returned. There are no log files to check in apache.

Can anyone help?



Are there any errors in the browser console?

You shouldn’t need index.php in the URL, it may be a sign that mod_rewrite isn’t enabled.

Mod_rewrite is enabled.

There are no errors in the browser console.

In the network tab are all requests loaded correctly?

You may want to try with the desktop or the React app by setting set_react_as_default_ap to 1 in the accounts table.

I’ll try the React App.

as regards the network tab…

Is APP_URL set correctly in the .env file?

I guess not. I originally set it to the correct ‘final’ url once I have it up and running.

However, I’m only wanting to set this up for local host at the moment to validate all the processes. What would the APP_URL be set to for that to work on localhost? Like this?? ===> http://localhost/invoiceninja

It may need to be http://localhost/invoiceninja/index.php, ideally it’s better to remove index.php

Thank you. All sorted now. Best regards

Glad to hear it, thanks for the update!