Self Host Install without Composer

Hi,

I´ve read the link articles for self hosting invoice ninja, but I don´t want to install the composer. Is it possible to install invoice ninja without the composer?

I´ve uploaded and unzipped the files. Database is created and nginx conf is created and active. But there is no setup folder. When I try to access /setup I get: No input file specified.

What is the exact way to setup invoice ninja?

Best,

Ben

Hi,

Composer is only needed if you download the files from GitHub. If you use the zip from our self host page (https://www.invoiceninja.com/knowledgebase/self-host/) the vendor files are already included.

‘Setup’ is a route, not a folder. You may want to check that mod_rewrite is enabled. Using the Bitnami installer (https://bitnami.com/stack/invoice-ninja) can be a much easier way of getting setup.

Hi,

thanks. There was set the wrong fastcgi host. Now I get to the setup page, but after click on submit I get Whoops there went something wrong. No error at the error log, I tested mysql connection und sent a test mail. What could be the problem?

Best,

There are usually two error log files: the web server log and the Laravel log at storage/logs/laravel.log

Webserver Log is empty. Laravel log has old errors, which are not referenced to the current time. This is an old error:
production.ERROR: Illuminate\Session\TokenMismatchException [0] : /var/kunden/web1423/www/ninja/vendor/compiled.php [Line 2548] =>
{“context”:“PHP”,“user_id”:0,“user_name”:"",“url”:"/setup",“user_agent”:“Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.130 Safari/537.36”,“ip”:“62.249.64.”,“count”:1}

You can enable showing errors to the screen by setting APP_DEBUG to true in the .env file.

Thanks! proc_open was disabled. Could you post the link to translate invoice ninja?

https://github.com/hillelcoren/invoice-ninja/blob/master/resources/lang/en/texts.php

Maybe it is helpful for someone:

I change the Setting “PHP support”, PHP run as “FAST-Cgi” to “Apache”, and it works.
http://stackoverflow.com/questions/14555996/no-input-file-specified

Thanks for sharing the solution!