Reports: wrong results per financial quarter | v5.2.16-C56

Hi,

When generating reports, if I select “last quarter”, I’m actually getting results listed from the current quarter, with invoices sent in July being listed:

This is how I understand financial quarters:

Is IN using a different definition of “last quarter” (which IMO currently means “from the beggining of April to the end of June”), or is this a bug?

Thanks

Thanks, we’ll look into this.

1 Like

This is clearly broken, we’ll have a fix in the next release.

Thanks for catching this!

1 Like

Well, there was a couple of releases in between but I still see this issue. Its reproducible on ALL reports where a date/invoice date/payment date/due date/quote date/valid until/start time/end time is present or can be added. Its also present in the Dashboard: If I select “Current Quarter” (I’m writing this on Sep 11) I get Oct 1 - Dec 31. If I select “Last Quarter” I get Jul 1 - Sep 30. So quarters are essentially off by 1, seems like something numbers quarters 0-3 and something else expects 1-4. But beware, resolution of :QUARTER works correctly, so don’t break it.

Furthermore I’m missing a way to order and/or remove columns. With “Columns” I can add columns to reports, but to remove columns I can only “Reset” which gives me the original set of columns, which cannot be removed. (I have no use for the “Client” and “Invoice” columns on the expense report.) Poor man’s sorting can only be done for non-default, added columns by the order in which I add them, but not for the default set of columns, also because there is no way to first delete them.

The Quote Item report lists all invoiced items and thus looks exactly the same as the Invoice Item report, although I have not created any Quote. Shouldn’t the Quote Item report be empty in that case?

And finally, there seems to be an issue with exporting. If I select “Report”->“Invoice”, “Group”->“Number” and then press Export the exported file looks like
Number,Count,Amount,Balance
R-2021-0001,1250,0,
R-2021-0002,1400,0,
I have invoiced amounts between 200 - 800 EUR. As you might notice, other than in the header there is NO comma between Count and Amount in the data, but instead there is an extraneous comma at the end. The data set should instead look like
Number,Count,Amount,Balance
R-2021-0001,1,250,0
R-2021-0002,1,400,0
Happens with other reports too. As far as I can see always when the first column of the report has a parenthesized number attached to it.

Thanks for fixing.
PS: When are recurring expenses coming back?

I can replicate the quarter and quote item problems, to be fixed…

I think the x to remove may be white on white so hard to see, if that’s the case what accent color is selected on Settings > User Details.

I’ll look into the export issue.

Thanks for all of the feedback! Recurring expenses should be ready soon, we’re just finishing it off.