Reports export Euro currencies with comma as decimal

We invoice in multiple currencies, namely USD, GBP, EUR.
Our Euro clients are based in Ireland, so their decimal should be a full stop and not a comma.

Is there a setting somewhere to change this. I don’t want central European formatting of EURO currencies.

Also would be nice to have an option not to include the currency symbol in the Net and Amount totals, maybe as additional columns that can be selected in the report.



If you set the client’s country to Ireland it should use the correct formatting.

Hi @hillel

I changed the clients county to Ireland, but its still displaying the Euro currencies in 0.000,00 format.
It seems the reports are hard coded to 0.000,00 format for Euro currency.

Screen shot from Report section, which also is exported in CSV the same way.

Also when I looked at changing the localization settings specifically for those clients, there is no setting for 0,000.00 format. See screen shots below.

Which country and currency are set at the company level?

At company level the default Country is set to UK, and currency set to GBP.
But we have two companies, UK and US, so we use two groups to change settings for different US or UK customers like address and currency etc.
All USD customers are assigned to the US group, and everyone else like GBP, EUR, AUD etc are assigned to the UK group.

Default Company Settings

UK Group Settings

US Group Settings

Thanks for the details, we’ll look into it.

1 Like

Any update?


This should be corrected in the next release, probably within a few weeks.

1 Like