Recurring Invoice V5 Pending and Not sending

Sort one problem and on to the next.

I have followed every tip and i can not get recurring invoices to send just stay as pending.

Any Ideas.

Hi,

Are the crons enabled?

@david do you have any suggestions

tried that everything how it should be

Recurring invoices are sent on the hour.

The only reason they won’t send is if the crons are not firing the schedule:run command.

I will try again and get back to you

1 Like

I have the same issue, Cron Job running no errors, but the recurring invoice keeps pending

Hi Leo,

How are you verifying the cron job is running?

I am also having this problem, my cron job is running, it wasn’t at first and I had a warning, after setting it up the warning went. I have also run PHP artisan schedule:run manually but they are just in a state of pending.

I also have this issue, very frustrating. I have over a dozen invoices that need to go out. Crons are working and I tried a manual php artisan schedule:run but nothing works.

Same issue here which I haven’t been able to figure out.

@studio-lumionus

Have you tried the webcron to see whether this resolves the issue:

https://invoiceninja.github.io/docs/self-host-troubleshooting/#webcron-configuration

I haven’t tried that yet. I’m waiting to see if the settings you shared with me before in the slack channel will work. I have my own headless ubuntu server I’m hosting it on and the crons seem to be working. I’ll know in a couple weeks and let you know.

For anyone reading here’s what David wrote: #1.In settings, workflow make sure auto send enabled. #2.Auto billing. In setting online payments change from due date to on send date