Quest to make AWS S3 work with InvoiceNinja

Round two.
I’ve tried this before without success. If anybody achieved this, please share how.
Seems like Ninja ignores AWS settings. There is 0 output about AWS config in logs.

Documentation I use for config:

#AWS S3 config in .env file

Setting up all the AWS_* variables didn’t do a thing.
So I tried changing the FILESYSTEM_DRIVER to s3 - nothing happend.
Setting up FILESYSTEM_DISK to s3 - didn’t change anything.

I could upload documents with 0 issues and there is no complains in logs. Running in debug.

Sorry for reviving a dead thread but did you have any luck with this?

I’ve been trying to get this working with R2 on a self-hosted zip install, pretty much the same config as above but with the r2 parameters as shown here

There seems to be very little documentation on how to successfully set this up, and less evidence of people having any success with it?



I gave up.
I couldn’t find any evidence of the system even trying to engage in communication when non default driver is setup. No logs (debug and extended logs are on), no errors, nothing. I went as far as digging in the Laravels code to see if Invoice Ninja documentation is close to reality. All I was able to figure out, that it was a bit outdated - but even using fresh env parameters - still didn’t have success.

Strangely enough, all other topics do get replies from devs here. But not this one, silence about AWS or R2 setups. At least in my case. So with silence from the devs, not enough interest from the community - I’ve resorted to using the default method.

My latest thought was that this could be reserved for exclusively.

1 Like