Problem changing invoice number

Dear support team,
I’m trying to change my invoice number.
In preferences I’ve set a counter which starts at “0005” with this pattern “S-{$year}-{$counter}”, I save and I get the confirm message “The next invoice number is S-2017-0005”.
When I create a new invoice through zapier (I don’t specify the number in order to get it automatically), the next invoice is always s-2017-0011, while the correct one would be S-2017-0005
Could you help me with that?


It looks like there are two problems: the s is lower case and the counter is off.

Are you using our hosted platform or are you self-hosted, if self-hosted which version?

Also, can you check what the quote counter is set to.

the counter is set correctly, see the img attached): [removed image]
When I create a new invoice, manually as well, it starts with s-2017-0011

I’m not yet sure why but the database has the counter set to 11.

Can you please try re-saving the settings page and then I’ll recheck the database to see if it updates correctly.

Done, I’ve re-saved with the correct number

I’m still seeing 11, are you seeing a ‘Successfully updated settings’ alert after the page reloads?

Please try logging out and then back it to see if it helps.

Yes, all is saved correctly [removed image]
I’ve logged out and in, same situation