Printing client’s signatures on paid Invoices

I need to be able to add a signature to a printed version of the PDF invoice. I have customers already signing before they pay for the invoice but I also need their signature to be printed when I mail their invoice to them. How can I get that accomplished? I don’t see a shortcut code that I can add the PDF file… Thank you for your help.

*I have Show on PDF Enable
Show the client signature on the invoice/quote PDF.

Self-hosted version v4.5.4 | White labeled

Are you using a custom design/does using a standard design fix it?

Yes I am using a “custom” template, but the only thing that I customized was the logo size and font size. I have also tried different standard templates and none of them are displaying the signature when I save the PDF for printing. DO you have an example of how the signature looks on the printed PDF? How can we fix this… is there a line of code that I can add? Thank you.

Can you clarify what you mean by “when I save the PDF for printing”, are you seeing the signature on the PDF when viewed on the screen?

… What do you do if you need to print a PDF invoice in Invoice Ninja? You save/download the PAID Invoice PDF to your computer.

“are you seeing the signature on the PDF when viewed on the screen?” NO - I have never seen signature showing up on any PDFs default or customized nor there is any information anywhere in your support docs on how to troubleshoot this issue.

How do you make a signature that customer applies before they pay the Invoice show up on the paid invoice in the Invoice Ninja?

You should just need to enable the option in the settings.

I’m not able to reproduce the problem, maybe check in a different browser?

I would appreciate a bit more context than just “Try a different browser”…
I figured out what was the issue myself. It was a missing “$signature”, on all invoices for some reason. So if someone is having the same issues after updates just make sure that your selected design has this string towards the end:

{
“columns”: [
“$notesAndTerms”,
{
“table”: {
“widths”: [
“*”,
“40%”
],
“body”: “$subtotals”
},
“layout”: {
“hLineWidth”: “$none”,
“vLineWidth”: “$none”,
“paddingLeft”: “$amount:34”,
“paddingRight”: “$amount:8”,
“paddingTop”: “$amount:4”,
“paddingBottom”: “$amount:4”
}
}
]
},
“$signature”,
{
“stack”: [
“$invoiceDocuments”
],
“style”: “invoiceDocuments”
}
]

Glad to hear you were able to solve it.

My original suggestion was to try a standard design, are you saying the standard designs are missing the $signature variable?