Prevent Invoice Emails from Going to Spam


I am self-hosting Invoice Ninja. Pretty much every email I send through the app goes to my clients’ spam folders. I normally end up having to download the PDF and send it directly from my email, although I have even had this go to clients’ spam folders before as well.

Is there anything I can do to possibly alleviate this problem?


If emails sent directly from your account are also going to spam I wouldn’t think it’s related to the app.

You may want to try using a different email provider.

It appears the directly sent one was just a one-off event as my other clients receive them just fine that way. Is there anything I can do to prevent, or at least reduce the chance of, email sent through InvoiceNinja from going to spam?

You can try using a service like to check for ‘spamminess’.

Hi Hillel,

Is there a way to send a test email? Or do I need to create a fake invoice an use it?

Also, thanks for the tip. It seems my web-host doesn’t have a DMARC record setup. I’m going to contact them, so hopefully they can get that resolved.


You would need to create a fake invoice or user to test it.

Hi again Hillel,

So it turns out there was something the matter with the SPF record on my domain. A2 Hosting stepped in and got that resolved.

I just created a fake client and sent a fake invoice to My SPF record checks out, but I am receiving the following errors that seem related to the actual application itself:

Checks if your newsletter contains broken links.
[591 - Error : Url not formatted properly] //,700,900,100
[403 - Error : Forbidden]

The last one I think is just because I’m hosting my InvoiceNinja on my subdomain, but my actual domain isn’t set up with anything yet. At least that’s what I’m guessing. However, in the app I do have the URL set to with the HTTPS required checkbox checked.

I’m not sure about the 591 error.

I don’t think those errors will cause your email to go to spam.