Populate database

Where do you populate the database that Invoice Ninja is using?

Setup keeps complaining that it can’t find the account table in the database. Database is indeed empty. But the install instructions don’t give any insight on what to populate the database with.


It may help to run php artisan migrate

That doesn’t appear to do anything.

@david do you have any thoughts?

There doesn’t appear to be enough logging.

It would also appear that this product has a high reliance on exec() in PHP. Instead of running code natively in PHP, the system hands that off to other processes through exec().

Now I’m getting an error where public/setup/check_pdf is generating an Internal Server Error - but there’s no logging information giving any details.

Have you checked both the web server logs as well as the application logs in storage/logs

Nothing being reported in either the web server error log, php error log, or laravel log.

I see the Internal Server error in the browser’s console window.

Going to public/setup/check_pdf directly generates a 404 file not found.

I’m starting to gather that Invoice Ninja doesn’t work in a shared hosting environment.

And probably doesn’t work in a sub directory either.

I’m not familiar with a /check_pdf route

I suggest checking the correct database credentials are set in the .env file

It’s in the Invoice Ninja Setup part.

Clicking the Test PDF button - gives “Oops, looks like something isn’t correct!” - and if you watch the browser console while doing this it shows an Internal Server Error from - public/setup/check_pdf - which if you visit directly gives a 404 file not found.

Is the only problem with the PDF? The info here may help:


I finally scrapped that install and tried another one.

The php artisan migrate step seems to be missing in the installation guide. It looks like that step is required to populate the database.

The next problem I ran into was that the /public/setup page looked off, it was not rendering the app.js and app.css files correctly.

Links to public/index.php/setup/js/app.js were leading to a 404. I did manage to complete the installation, but was never able to get the app.js and app.css to render correctly.

I might encourage people that work on the development of Invoice Ninja to try and install Invoice Ninja on a shared hosting account - one where you don’t have root access - and see what issues may come up so that a guide can be written better.

Thanks for the feedback!

cc @david