PDF naming prefix on download not in the right language (v5.6.4-W121)


Starting recently (I noticed it only today, but I haven’t invoiced for the past few days), when I download an invoice, the prefix is in English rather than my localized settings (FR_CA). It used to be “Facture_xxx.pdf” and now it’s “Invoice_xxx.pdf”. I don’t know if someone modified the translation improperly or if it’s a bug where the naming just reverts to the default language configuration. Any ideas? Thanks!


Which version of the app are you using and where exactly are you downloading the invoice?


I’m using the v5.6.4 Windows app I’m downloading locally on my PC.

To make things clearer, the prefix I’m talking about is not related to the generated numbers recipes, but rather the additional prefix telling the entity type (Invoice, Quote, etc.) that is automatically added by IN to the file name upon generating a download.

Thanks, we’ll look into it.

1 Like

Hi @hillel,

The issue is still there in v5.6.7. Do you know if there is a way to just turn off the auto renaming, maybe by changing some flag in the DB? For now I have to rename every downloaded file manually and it’s a bit annoying.

BTW, the PDFs used to be named exactly the way they appear in Invoice Ninja v5 - I even added my own prefix to the naming scheme to make sure what is what (“F” for “Facture” (invoice), “S” for “Soumission” (quote), and so forth. At some point the app started to add the prefixes automatically (maybe last year, I can’t recall for sure), but I didn’t care that much since it was in the correct language, it was just a bit redundant - “oh well”, I thought. But now it’s a bit more invasive since:

  • I don’t really want or need the auto prefix adding;
  • It’s not even in the right language so I have to delete it (or rename it) manually anyway.

Is there an option or toggle switch somewhere to control that behaviour that I missed?

Where in the app are you downloading the PDF, can you please post a screenshot?


Sometimes I download the PDFs from the lists directly:

But sometimes too from the edit page:

Both produce the same outcome (screenshot from Windows Explorer):

Thanks, @david any thoughts?