Payment Button not working when setting up SEPA Direct Debit

I’m trying to get recurring invoices setup with GoCardless. When testing, I get through to where the user is prompted to pay the SEPA Direct Debit but the ‘Pay Now’ button has no link (see screen shot). The ‘Add Payment Method’ does work but this can be a layer of confusion I would like to avoid.
Thanks for any help.


@david can you please advise?


I’ve checked in a fix for this, available after our release this Sunday.

@david @hillel
Can I ask one more question please. I’ve noticed that the same happens if you select Bank Transfer /Direct Debit option from the previous screen (see screenshot below). Is there anyway to remove the Bank Transfer/Direct Debit option as I only want my clients to use the SEPA Direct Debit? Not a biggie, on if it’s a setting that I need to change that you can point me towards.

Hi @NiallCon

You can certainly control which payment methods are displayed.

In Settings > Payment Settings. Edit your GoCardless gateway and go to the Settings tab. In there you can toggle which payment methods can be made available through the application.

@david Thanks!
I tested the functionality of the original post. The ‘Pay Now’ button is now not showing at all but the ‘Add Payment Method’ link is. No big deal but it’s better to not have a button that doesn’t work but I think others might want the ‘Pay Now’ button back :slight_smile:

The button will appear when a payment method has been created

@david Thanks. I’ll test that in the morning :ok_hand: