Number-prefix not being generated

Having set the recurring-prefix in the numbers-settings to “2022”, I’d expect invoice numbers generated to be something like “2022-0001”. Creating a new invoice, it still generates a number in the likes of “0001”.

Am I misunderstanding this setting, or are there any other settings having to be set for it to work?

Running on the latest build via docker-compose.


The recurring prefix is only applied to invoices generated from a recurring invoice.