Not able to update company address

Hi, I am not able to update City/State/Postal code on a company I created on a brand new installation. All other settings can be changed but some settings do not reflect on the preview invoice design. It’s stuck with Beveley Hills, CA, 90210 and Country Always United States. Is this normal? I changed my company address and saved a few times and repaired installation. Please help.


Can you please post a screenshot of the company settings?

What do you see on Settings > Company Details?

@david do you have any suggestions, I assume the “Beveley Hills” value is mock data?

1 Like

That’s what I thought, but most of the fields reflect correctly after the change but not all. Even for client info, the number can not be removed (Ln 2).

Which version of the app are you using?

You should be able to update which client fields are shown on Settings > Invoice Design.

I’m able to make changes but only some changes appear as the company street address and apt but no city, code, or country. When i remove it so it does not show, then it does not show but then when i add it back it’s always Bevely Hills and United States, instead of Toronto, Canada. Same with Client info. some info reflects correctly when changed but then other does not.

Is it possible you’ve set custom settings at the client or group level?

Itr’s a brand new installation. No clients and no groups.

Is the cron running?

It may help to post a screenshot of the health check dialog.

Thank, do you see a difference if you change the PDF renderer to hosted_ninja?

Where do we change that?

It’s set in the .env file

It’s set to PDF_GENERATOR=snappdf
Can we set it to something else? Not sure. It’s on Ubuntu 22.04.3 LTS

You can try hosted_ninja

set it to PDF_GENERATOR=hosted_ninja and restarted app/re-login. Still the same.

Have you tried viewing the invoice in the client portal?