Ninja logo appearing on invoices after upgrade from V4 to V5


I’ve decided to give V5 a try - I’m not entirely loving it just yet.

Must say, the migration was very simple however!

Anyway, first issue I can see is that for some reason the Invoice Ninja logo is appearing on my invoices, now I do have a white label license and it is registered as it was moved over as part of the migration. So what do I need to do to get rid of this logo?

I don’t have a logo to upload as I don’t use a logo.


I don’t know what the official way is, but if you upload a white image as a logo I think the invoiceninja logo will be removed.


So unlike V4 where it does what it’s meant to when you’ve applied a white label license and removes the logo, you have to do a stupid workaround?

So there’s that plus sending emails via 365/gmail that doesn’t exist.

Upgrading to v5 seems more hassle than it’s worth.

I think this is just an oversight, we’ll make sure it’s corrected. cc @david

I’m not sure I understand your problem with 365/gmail, can you please explain?

I understand what you mean from the email you sent.

This is a new feature for the v5 hosted platform. In v4 all emails were sent from, v5 hosted users can now send emails from a Gmail or 365 email address. This has always been supported by both versions of the selfhost app.

@david any thoughts on creating a webpage to manage the .env file settings?

Sounds like he just needs to upload his own company logo?

I believe he may not have a company logo, I don’t think the Invoice Ninja logo should be included by default.

Thanks for the reply.

Ah maybe I’ve misunderstood regarding emails. Basically I can’t see any options under Email Settings to enter 365 settings or anything? I was assuming it was a connector of some description as my experience in using 365 as SMTP as painful to setup manually.

Regarding logos - I don’t have anything exciting as a logo unfortunately. I was expecting it to act the same way as v4 you see.