New Sofaculous install 5.7.5 500 Server Error :-(

Hello. I’m installing a new version of 5.7.5 on my VPS. PHP8.1.

I have installed via Sofaculous and while the install went OK (once I’d turn on some extensions) when I go to the admin URL I get a 500 server error page.

I have read previous comments and checked /storage/logs/ but all it contains is a file called .gitignore. There are no error logs or other files in this folder.

I have searched the forum but didn’t find anything useful.

I have v4 running on some shared space, and recall a similar issue, but it was setup years ago and I can’t recall how to fix or troubleshoot. So Im hoping some smart people here and help me get v5 working.

Many thanks.


Are there any errors in the web server error logs?

It may help to temporarily set APP_DEBUG to true in the .env file.

Hi, thanks for the feedback.

I can see nothing relevant in the server error logs. I have set APP_DEBUG to true.

I do have a file in the IN folder called error_log. It contains the following lines…

[05-Sep-2023 09:13:53 UTC] PHP Warning:  Constant PASSWORD_DEFAULT already defined in /home/xxx/site-xxx/invoices/update_pass.php on line 17
[05-Sep-2023 20:18:01 UTC] PHP Fatal error:  Allowed memory size of 33554432 bytes exhausted (tried to allocate 528384 bytes) in /home/xxx/site-xxx/invoices/vendor/composer/autoload_static.php on line 1181

I am presently having my server guy check that all extensions are in place for PHP8.1, as per the requirements page on the IN website.

I should perhaps add that IN is installed at as opposed to as a sub-domain. Not sure if that is relevant to the issue. My version of 4 is installed on a sub.

Have you tried

I haven’t, but then I don’t really understand what /update?secret=your_secret_in_env_file means!

Can you elaborate?

EDIT: OK, I’ve looked in the .env file and there are references to “secret”, but I’m not entirely sure which value i should be using. I’ve tried the URL you gave me with various things that may be the secret, but nothing.

That said, if my understanding of the URL is correct, it’s saying run the file name “update”? I have no file called "update either at the root of the IN folder or in /public/

So I’m not sure what you mean!

It may help to increase the PHP memory limit

HI, I have tried that, but no luck.

I do recall similar issues installing v4, and I think it took a good few days to resolve. I think using this forum. But, I’m not sure how commited I am to putting that effort in for v5!

I’ve not used V4 much, as Stripe (my main processor) does invoicing. But they are now charging for all invoices, so I plan to push everything to IN. So that’s invoices going out for about four businesses.

With all that said, I’m now considering just going for the hosted option, and letting any issues along the line being someones elses problem :slight_smile:

So, if anyone has any bright ideas as to how to get my self-hosted version working, I’m all ears. Otherwise, I’ll just start paying for the pleasure of using IN.

Have you tried adding /setup to the admin URL?

I have, but there is no /setup/ folder anywhere.

/setup is a route, there won’t be a folder for it

OK, so if my URL for admin is Admin URL : what URL would I be using the setup?


@david can you please advise?

  • Should mod_rewrite work out of the box with Sofaculous

  • If it doesn’t work do you know how they can access /setup

It’s worth noting I’m surprised to see the “Constant PASSWORD_DEFAULT already defined” error, I think this variable was only used in v4.