Moved from Plesk to Cpanel, Invoice Ninja stopped working

Getting desperate here…

I recently moved my websites from Plesk to Cpanel and now Invoice Ninja wont work. It shows the login page but will never login, always redirects to the login page. After submitting the form it will briefly show ‘REDIRECTING TO <URL>/dashboard’ but it’s a no go.

I’m pretty sure it’s some configuration on WHM or Cpanel but I can’t quite figure out what. Tried clearing browser cookies but that didn’t help. Checked .htaccess and files and folders permissions and they are correct. Database connectivity is fine. Server runs PHP 7.2 and Cpanel uses Engintron. All other websites are fine, Wordpress websites can login just fine as well.

Observing the situation leads me to believe it’s something related to Apache and cookies but I am not versed enough to figure this one out. Searched the web for some hours now and nothing came up. Does anyone have any ideas? I’m almost paying someone to check this out for me.

I agree it sounds like a cookie or session issue but I’m not sure what would cause it.

Are there any errors in the web server error logs?

Not at all. Not even Laravel logs show errors. Really it might be that Invoice Ninja is trying to set a cookie and Apache is rejecting, or something like that.

I also tried disabling Cloudflare, that didn’t help either.

You may want to test with a clean install of the app.

Hillel’s probably seen this a million times :slight_smile: Yeah, a clean install did the trick. Now on to figure out how to proceed.

Alright, figured it out… Just had to replace the files from the current installation with a fresh download.

Thanks Hillel!

…aaand that was fast, it stopped working again.

Hi Hillel,

I wrote something else on this reply but I think I know what actually caused the problem.

The changes in v4.5.11 are extremely minor, I think it’s very unlikely it’s related.

I have a customized brazilian portuguese translation. When I uploaded the app it logged in just fine but as soon as I restored my translation over your translation it stopped working again.

Oh my… Adventures in debugging, I guess?

We advise updating translations here:

Thanks, I’ll contribute things there but the reason it is customized is that there are some things specific to my company.

Still, I’m curious to know why this problem presented itself like this. If there are missing translations and that is causing a fatal error in the application, why nothing showed up on any log anywhere?