Module Install Error

Hello everyone,

New to forums but I’m here trying to figure out a resolution to this issue.

I am able to install v4 and v5 on my shared hosted box running cPanel. The apps run fine (both versions) but I’m trying to get the tickets module installed and when i run the following command for either version I run into an error:

COMMAND: php artisan module:install invoiceninja/tickets --type=github

Cloning into ‘/home/cloudwis/’…

ssh: connect to host port 65001: Connection timed out

fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

Running for module: Tickets

In FileRepository.php line 396:

  Module [Tickets] does not exist!

Anyone have any idea why it’s doing this? I can’t nmap to test port, but is there a way I could install this without the artisan command? Maybe manually upload the folder with the module files?


Using the tickets module requires using the develop branch of the v4 codebase.

Ah okay that makes sense. And where would I find that version? Github I presume? Do you by chance have a link?

Thank you. So I take it v5 has no develop branch yet?

The v5 develop branch is here but it doesn’t have the tickets module

Darn… Okay well thank you very much for your help!

Sorry one last question… How do I install the develop branch? After uploading files, going to i get a 404 error and I don’t see any further instructions on install of develop branch. What am I doing wrong?

Which version are you using?

v4 develop branch. My goal is to try out tickets system.

The docs are here, I suggest checking the web server logs for any errors.

Right, but for some reason step 4 is where i’m getting an issue


I’m stuck here, i get a 404 error because the setup page does not exist lol
Going to the file directory just lists the files

I suggest checking the logs for any details, a 404 implies a server configuration issue.

Note: you may need to add /public to the URL

Only errors I get are as follows:

2021-03-23 14:41:42.521813 [INFO] [385901] [] File not found [/home/mydomain/]
2021-03-23 14:41:42.521768 [INFO] [385901] [] File not found [/home/mydomain/]

It’s thinking the file is missing. I’ve tried with and without the rewrite rule in .htaccess. With it on, I get an error 500.

Guess I might as well just give up lol -_- Was worth the attempt i guess :man_shrugging: