Migration to another server results in 500: No Company Found

Since I did not find any documentation on how to migrate between servers, I took it upon myself.

  • I followed this repo that I used for both installations.
  • I got everything running and can log in with my inital user.
  • Then I do the database migration. I create an SQL dump of my old MySQL DB and push it into my new MariaDB (Had to change databases due to different architecture).
  • Now the Login mask recognizes my old user credentials and even the 2fa is working.
  • But when I want to log in with my correct credentials, I just get a message inside the login mask:
    500: No Company Found

Even after rsync’ing every volume from my old app container to my new app container, I get the same error.

Can anybody help or guide me through migrating between servers?


Can you explain what you mean by “the Login mask recognizes my old user credentials”?

I found this post with a user reporting the same error, in their case disabling and the reenabling 2FA helped.

`500: No Company Found / 500: Server Error` at login - #9 by jsenecal?

Disabling 2FA using this command update users set google_2fa_secret = null; worked, thank you

Glad to hear it’s working, thanks for the update!

@david there seems to be a pattern here, migrating Docker installs with 2FA enables causes a “500: No Company Found”. Not sure if there’s a code fix but thought I’d point it out.