Migrate from v4 to v5

Hi everyone.
I am new to this and has a huge problem migrating.
1 it told me to up my PHP…I did
2 didn’t have enough space… I upped my package at hosting company.
3 i installed and it worked… but all my clients and invoices are gone.

I do have a .sql file of my database, but can not get it to work.

any help would be highly appreciated. I am a 1 man business based in South Africa and don’t know who to ask.

Your new Ninja


Did the migration complete?

Are there any errors in storage/logs?

-Migration from ver 4.5.46 to 5.3.29
I’m not sure what my ver4 was before i stuffed this up.

cant import because the tables are different

I think I need to role backwards till my backup imports then take it up step by stem.
what do you think.

while im trying to do all this I have clients with problems I have to sort out…lol not complaining

where are you bassed ?.

It sounds like you may have tried updating your v4 app to v5 rather than setup v5 as a new app and use the v4 migration on Settings > Account Management.

I couldn’t say it better.
Can it be fixed?

Do you have a backup you can rollback to?

Copying over the latest v4 version may help.

I have a backup of my database. That database can not be pulled into ver 5. It is complaining about the tables. I have a ver4 also installed, but that didn’t work either.

I suggest using the backup to restore v4.

To upgrade from v4 you need to install v5 as a separate app and then use the migration tool in the latest version of v4 on Settings > Account Management.

Will any ver 4 work?

I suggest using the latest v4 version

Would there be any way that we can talk to each other?

Im so desperate to get this fixed. I would like to show you what I have?

You’re welcome to chat with us on Slack if you prefer.


I actually wanted to whats app call you if possible.


Sorry, we aren’t available to speak on the phone.

I installed v4, It opens and i can get in. its empty so I want to import my data so that I can migrate.
when i click on settings i get the above error.

what about temviewer?

You can use mysqldump to copy over your database.

Sorry, we aren’t available to help via teamviewer.

Im so happy. I got 4.5.46 to work.

Then i installed v5.3.29.

Now i want to migrate…

It is asking for API_secret

If i leave it blank and click continue

I get this…