Microsoft Edge - Logo not showing

When my customers open the invoice link in microsoft Edge, the logo in the header of the invoice doesn’t show up. It works fine in Microsoft Explorer though. Chrome works fine as well.
I tested this on a few different computers and they all did the same thing in Edge.
Is there a way to fix that?


I think it’s related to this issue:

It may help to try with a different image format, ie: jpeg.

I tried switching the logo to Jpeg but still the same issue, the logo doesn’t show up when viewed in Edge. I also tried this on a few different invoice templates, but the same problem happens.

It would be less of an issue, but the default browser on Windows 10 is Edge. So this could effect a lot of clients…

Any other suggestions?


Also same issue here, only on Edge no logo is shown in the preview. When downloading PDF through Edge also no logo.

I am not using the internal PDF viewer at this moment due some other little issue, the logo might work when this is enabled.

In our next release we’re updating to the latest version of pdfmake, it may help…

Ok, I just got this to work on Edge by converting the logo image into a dataURL format.
In the custom design settings, I inserted the crazy long dataURL code into the spot for $accountLogo

I’m not sure this is the right way to fix it, but it works.

Is there anything wrong with doing it like this? or should it be done differntly


That’s an interesting solution, thanks for sharing it!

If it works…

This actually works great (on all browsers tested now: Edge, IE, Chrome, Firefox and Safari)

Used to convert my logo into dataURL. Thanks for this suggestion!

…My header template has gotten very big now so might be a better solution someday, but for now, thank you Maff!

Converting the logo image into a dataURL format. Interesting solution. Edge has some sync problem.