Litespeed - Mariadb and directadmin - Install Loop


I’m trying to install V5.

On a subdomain.

https demov2 .mydomain .com

I followed this instruction

and changed public to this:

RewriteEngine On RewriteRule "^.env" - [F,L] # RewriteRule "^storage" - [F,L] RewriteRule ^(.well-known)($|/) - [L]

RewriteRule ^(.*)$ demov2/public/$1 [L]

But then even after restart of the litespeed the link gets a 404, when I change it back to just
RewriteRule ^(.*)$ public/$1 [L]
The setup link works… :s
All test in the setup are success, but I always come back to the beginning of the setup page.

I saw this:

But do I need to do this on a server. Mariadb is installed, I got other Wordpress websites running on this server as well so, not sure what to do.

ps: I don’t have invoice ninja v4, I’m a newby (currently I’m using invoiceplane)

update found this under storage/logs/laravel.log

Error Output:

sh: mysql: command not found

[2021-06-24 20:20:40] production.INFO: account table not found
[2021-06-24 20:40:59] production.INFO: The command “mysql --user=”${:LARAVEL_LOAD_USER}" --password="${:LARAVEL_LOAD_PASSWORD}" --host="${:LARAVEL_LOAD_HOST}" --port="${:LARAVEL_LOAD_PORT}" --database="${:LARAVEL_LOAD_DATABASE}" < “${:LARAVEL_LOAD_PATH}”" failed.

Exit Code: 127(Command not found)

Working directory: /home/admin/domains/


Error Output:

sh: mysql: command not found

If you’re seeing account table not found it may help to run php artisan migrate

that’s safe to do, with already an active db running with websites connected to it?

ps i just tried to run this command in putty but i got this:

root@srv:~# php artisan migrate:fresh --seed
Could not open input file: artisan

You need to run the command in the root folder of the project

of the project? you mean the folder where all files have been uploaded?

Correct, you should see these files in the folder

Howly cow, most diffuclt setup ever :slight_smile: But i’m getting there i guess.

The setup did continue now. But i got a 500 erro at the end.

I set APP_DEBUG=true in the .env file. And i saw this error:

The stream or file “/home/admin/domains/” could not be opened in append mode: failed to open stream: Permission denied

I’ve runned this

chown -R www-data:www-data /home/admin/domains/

and tried this

/home/admin/domains/ chown -R www-data:www-data storage

but with no results.I hope i’m getting close to get this working :slight_smile:
I really wonder if you have no dedicated server how you get to manage to install this on a shared hosting without having access to putty a lot of EU shared hosting don’t give you access to enter those commands.

ps: @hillel thanks for the assistance so far, appreciate your time.

think i got it fixed, i can now login :slight_smile:

with this commend:

/home/admin/domains/ chmod -R 777 storage bootstrap/cache

I only get this warning. I’m totally new to lavarel:

Do i need to delete the .env file ? or move it to a other folder? Debug mode is already set to false again.

Please check APP_DEBUG is set to false in the .env file

Note: we strongly recommend against using 777 permissions, 755 would be better.