Issues with view payment url

Hi Good Day everyone,

im facing an issues where Payment Status email notification "View Payment button didnt work. And honestly i just realize it today, after 3 different update version since the last i remember it worked. So i dont know from which version it started to failed.

When i click the “View Payment” received in the email, it brought to 404-Not Found page.

Laravel Log didnt provide any error log

My setup is as per follows;
Setup in sub folder :
Invoice Ninja Version : 5.3.78
Client Portal : Enable
Client Portal Settings : I dont set password nor required user to register. They just simply need to click the link and directly brought to the client portal.

Maybe anyone has an idea where i should start looking to fix the issues?

I might messed up something during upgrade, but as i only realize it few version after, i have no idea where it start to go wrong.

Additional info,
Quote Email with “View Quote” button works correctly.
Invoice Email with “View Invoice” button also work correctly.
And when the customer arrived to the client portal using quote or invoice button, they can move to the Payment tab and view the payment within the client portal without any problem.


@david do you have any suggestions?

My question is your install under a sub directory or web root for the url?

In the .env file make sure the APP_URL is filled out correctly, followed by the sudo php artisan optimize command under the webroot. This sets your InvoiceNinja webapp properly.

Then in the admin under settings: make sure the company url is setup correctly as that is what those view invoice, view quote, view (take your pick) in the email templates driven from. This is what for me since my site is under a subdirectory and that has to be defined for the links to work properly and for the app to find itself properly.

Hi i dont believe that the issues, as my env has been in used since 2021 and never change since then, and i confirmed last testing that it still worked on february 2022. So i believe its a bug somewhere.

And as per mention on additional info, everything else work, except for the view payment url.

And just this morning, i confirmed that it also happened on fresh install invoiceninja (5.3.76) via softaculous on totally different server than mine. So its probably a bug.

Whats version are you currently using?

Makes senses, if it’s just that one individual URL I would think it’s more likely a bug with the app.

@david thoughts?

Does your APP_URL include /public ?

This looks like a rewrite issue. You’ll want to include v5/public/ into your APP_URL by the looks of it?

Originally its like this


Then just incase i add “/” at the end of “public” became this;


But it still not working, if its settings in .env are the problem, i dont think that “view invoice” and “view quote” button will work, but in this case, the 2 buttons (received via email) work just fine. Just like i pointed out earlier, only “View Payment” button are the one that problematic.

And just incase i also made a fresh install as per my 2nd reply above, it also showing the same symptom where the email client received for payment notification that contain “view payment” button are the 1 and only that did not work

Dear Sir @david ,

I try to check the error through chrome console, and find this error, I have double check in all env, and all has this settings;

which is correct,

but on the error page the livewire loaded as this

as you can see, theres no /v5/public/ in the livewire request.

If im not mistaken, the correct way it should request; /v5/public/ vendor/livewire/livewire.js

Can you set the ASSET_URL to match your APP_URL in the .env file

It still try to GET livewire without v5/public

its tried directly to GET

which of course led to 404 not found

Run: sudo php artisan livewire:publish then delete the contents of the cache directory and retest. Post your results.

For Livewire issues, i decided to move from /v5/ to root subdomain, which means i move the installation to directly instead putting it in subfolder. Before this i didnt do this because theres another application that run in there, but i no longer need those apps, so i decided to remove and make the subdomain fully only for invoiceninja. So the limewire issues goes away.

And now whats left is the issues with view payment url, im still working with Mr David on this. but currently the solution not yet found.

Update: The issues has been resolved thanks to Mr @david . So this case is closed, i would like to thanks everybody that try assist me for this issues. :smiley:

Can you share the solution that resolved this? Or will this solution be part of the next update?

It will be part of the next update

great i have the same problem and wait for next update

after update to v5.3.79 it`s fixed… thanks for your work

1 Like

I am using 5.3.84 and I still have the problem.

I even installed on a subdomain and I get a half completed front page with a 500 server error in it. But if I click the link to go back to the subdomain under the error message it allows me to go to a client login, but that is it. I still can not log in

Are there any details about the 500 in storage/logs