Invoicing for service based businesses

One of the problems I had with the old Invoice ninja is that the whole system seemed to be primarily supporting and surrounding product based businesses, I’m looking at the new invoice ninja, and it looks alot like the old one, including the lack of features to support service based invoicing. Hourly charges and time and dates details for the invoices. None of the templates out of the box seem to have anything for services. Is there any chance there will be some more options on that front? Possibly some templates that are time based billing? Also, there’s still quite a few issues on browsing and entering or configuring settings. For example I was setting up terms and accidentally deleted Net 0. I went and re-created it but I could not find in it in the list from the drop down after saving it. I did this on the desktop and got this problem. On my phone I was able to see it and select it.


v5 is designed to be a superset of v4, the features are similar by design. v5 has some improvements to the custom fields feature which may help here.

If there are specific changes you think would help we’re happy to look into making them, I suggest searching for/creating issues on GitHub.

I’m not able to reproduce the problem with deleting/re-creating a payment term. Are you able to replicate the problem?

Yes I am. Although honestly, I’m having all sorts of issues, often arriving to just gray background pages. There may be a bigger issue here, but I’ve included some screenshots so you can see what I mean…

Sorry about the seperate post, but I guess new users are only allowed to post one image at a time?

Have you tried restoring the initial Net 0 record?

By restoring you mean simply clicking the Plus and typing 0 where it asks how many days? then yes. Is there some place to restore deleted items? Also, I can tell this setup is mainly geared to mobile devices. If I browse that same terms section on my phone I can navigate back and forth no problem but on the desktop it’s odd navigating mainly because of the lack of the back button that normally appears on the top left on mobile devices but doesn’t on the desktop. On the desktop, instead of going back I have to click on the whole category in the middle menu and then click on customizing the terms again.

By restoring I mean using the filters at the bottom of the list to show the deleted record and then using restore option so it’s active.

On the desktop there should be a ‘Back’ button in the top right corner.

You mean this filter? Keep in mind I’ve deleted the item twice and recreated a new one manually. the filter shows nothing deleted. Also, I’m having a hard time seeing the back button you are talking about can you see it on my second screenshot? I’ve marked a red ex on the only back button I can see. That one is to hide the menu and doesn’t take my “payment terms” pane back to where I was before. Only option I can see is to go directly to the basic settings menu and start my path over again.

Which version of the app are you using?

App? This is all being via browser, both desktop and mobile. I know there was an app with the old version but I never needed it, in fact often the app would kinda lag behind the website development so I haven’t really tried it on this version of Invoiceninja just yet. I could give it a go, but I’m not sure what exactly the issue(s) are here yet. Can’t tell if it’s my computer, my browser, my server installation or just bugs, but it’s alot of issues and I haven’t even tried to start using the app yet. This was all just from my setup of my initial install of the server.

Also, I am encountering another issue with selecting or clicking on items. Like at the login page, when I press the login button it often triggers the forgotten password link instead. Like the mouse cursor is offset by a considerable degree from the the visible arrow. This only happens on the invoiceninja installation I just did, so I don’t think it’s an issue with my computer or even my browser. There’s alot of these little kind of things and I don’t know if I should be starting new threads for each or if there’s something else fundamentally wrong that’s affecting everything.

I mean which version of v5, ie. v5.1.59

You can check by clicking the about icon in the bottom right corner

The version number in the “VERSION.txt” file says 5.0.21. Looks like I’m running an old version. Not sure where I got that from, I think I might have followed a link here on the forum instead of github. Can I simply overwrite the previous extraction to upgrade?

There is an in-app option to update but that older version of the app isn’t as reliable.

You can also copy over the latest zip:

Thank you so much! I should have known it was something wrong with my installation. It just didn’t occur to me to check the version number because I was almost certain I had gotten the copy from guithub. My browser has had the page up the entire time!

Ok, so last question. I tried to do the forced updated option in the about section but that failed FYI. So then I went ahead and downloaded and extracted the latest overwriting the previous files. I then set the folder permissions again, and did the pip artisan optimize and rebooted for good measure. So it had me go through the initial setup again, but I think there was an issue of some sort because it kept having me go through the initial tests over again in a loop. I rebooted the sever after trying 4 or 5 times and now I get a cool login screen with one time password options and more. Cool stuff, BUT when I attempt to login I get “500: Server Error” and I’m not sure where to go from there. If you think this could be complicated, I can just completely wipe and start over.

Are there any details about the error in the logs in storage/logs?