Invoices are saving as draft...?

I can’t seem to find the answer to this when I search the forum and it’s driving me nuts I checked invoice settings etc. I noticed when I create an invoice, then click save, it automatically saves as a draft for some reason…? How do I change this to just save as an invoice?

thanks for your help as always!

Hi, this is by design. Invoice is saved draft until you do something with it. There are several invoice statuses. By doing something this can be either sending it by email (‘Email invoice’), marking as paid/entering a payment, or marking it as sent (ex. if you sent manually through other channel). As soon as you choose any of those options, it changes to that status and no longer draft.