Invoices are going to spam

Hi, I just had a client reporting she found my invoice in her spam folder.
What’s happening? Isn’t there anyway to use my own SMTP server with Invoiceninja?

We use Postmark to send our emails, most get through but some get flagged as spam.

You can use your own SMTP server by self hosting the app.

Self hosting the app looks like a lot of work and probably beyond what I’m planning to do. It’s just invoicing. But they need to get to the client of course.
Any plans on implementing SMTP functionality into your hosted version of Invoiceninja?

We hope to add support for sending emails from a Gmail address using OAuth.

We don’t plan on supporting SMTP servers.

You could try adding spf to your domain. such as:

v=spf1 ~all

We have SPF and DKIM setup.

I meant on their own domain, if they are using their email as the sender and reply to address. and the email is not coming directly from their address it will get marked as spam a lot of the time.

Hi billyggla,
I am using a reply-address from my own domain. I don’t believe you can set the sender as coming from your own domain.
You think adding the invoiceninja to my spf record could clear things out?

I’d be curious to know if it helps.

By default we set as the sender and use the user’s email address as the reply to.

It’s worth a try, it may be because the reply to and sender are from different domain, if that is the cause then adding the spf record will sort it.

Hi billyggla,
awesome suggestion!
Are you sure it is and not

It should be v=spf1 ~all

Ok, thank you billyggla :slight_smile:

No problem, hope it helps.

I know more tomorrow. I happen to know the client very well. So I contacted her, send the invoice again and it went straight to spam. I then changed my spf record, but I’m going to wait till tomorrow before trying it again. I’ll sure report back here if it works.

It can take a few hours for the spf record to propagate anyway, so it would be better to wait to get an accurate result.

SPF records will only verify against the outbound mail server. Setting this record in the way suggested above will not work.

It sounds like your client needs to whitelist * in either their mail client, or with their email server.

Well, that spf trick did not work unfortunately. I guess DavidBomba is absolutely right.

And second invoice from InvoiceNinja went to spam. This is 2 out of 3.
I don’t have any particular problem with my e-mail.

Another option is to copy/paste the ‘View as recipient’ link and send it from your email address.