InvoiceNinja not loading after system update

Running Ubuntu 20.04, I have primarily InvoiceNinja on this server, I ran an apt-get update/upgrade command, the server completed that fine, but InvoiceNinja wouldn’t load. I tried to restart the server, still not loading, it would just hang and never complete the request. Now, I’ve got a default apache2 page at the invoices domain. My InvoiceNinja is using Nginx, but I imagine apache got updated and somehow supersedes the previous config? Any help anyone can offer to get back up and running? All files still exist on the server, .env, etc. are all still in place in /usr/share/nginx/invoiceninja. I could remove apache2 but worry if I do that I might cause more issues.



Assuming you can’t just disable Apache maybe this will help:

I wasn’t sure if uninstalling apache would affect it, I uninstalled it and now the default apache page is gone (obviously) but still not reflecting invoiceninja info on the page.

.env file contains:
APP_NAME=“Invoice Ninja






Is there a way to restart the invoiceninja service?

You could try restarting the Nginx web server.

That did it! THANK YOU!

Glad to hear it, thanks for the update!