Invoice Ninja v5.5.71-C107 - Email Settings

Can you help me identify where the email settings are please?

I just tried to mail an invoice and nothing got sent so I assume the mail settings need looking at.

I checked the following page:

And changed the settings but the laravel.log seems to be logging the email but not actually sending.

You can use the health check dialog in the app to check the mail driver being.

You may need to run this command after updating the .env file to update the cache:

sudo -u www-data php artisan optimize


I go this response for that command…

[root@server /]# sudo -u www-data php artisan optimize
sudo: unknown user: www-data
sudo: unable to initialize policy plugin
[root@server /]#

I think you need to change www-data to your web user.

You can also try running php artisan optimize but it may require you to reset the file permissions.

Thanks for that.

I did as you suggested and got this response:

[root@server public_html]# sudo -u bill01 php artisan optimize

INFO Caching the framework bootstrap files.

config … 35ms DONE
routes … 77ms DONE

X-Powered-By: PHP/8.1.16
Content-type: text/html; charset=UTF-8

[root@server public_html]#

I tried sending an invoice again and nothing received and also nothing in the laravel log.

Do you see the change applied in the health check dialog?

Are there any errors in the system log in the app?

Can you help me find the health check dialog?

You need to click the about icon in the lower left corner

Thanks for that

Here’s what I see.

It looks like the app is using SMTP.

Are there any errors in the system log in the app?

In the laravel log?

It seems to be dumping the entire email message into the log but then I changed the SMTP settings in the .env file and it stopped doing that but also did not seem to be sending the emails.

There is a system logs tab on the dashboard page in the app.

There’s more info about debugging this issue here:

Thanks Hillel

I checked that and it is blank.

@david do you have any suggestions?

I’ve done this before without any issues so I must be missing something simple, just don’t know what.

I think I have solved the issue.

I went to the mail account and changed the password.

I then updated the password in the .env file to the same password.

I went to an invoice and hot send and got the following error in my inbox:

I then changed the client email address in Invoice ninja to another I manage and hey presto the mail came through.

Any help appreciated.

It seems every time I install I run into the same issue with no solution.

Not sure I understand, from your previous comment I thought the issue was resolved?

Hi Hillel

I think the email issue itself is resolved but the cron job is not working even though it appears to be setup correctly. It’s confusing as heck so if you don’t mind I’ll update that thread as the two issues seem somehow to be connected.