Invoice Ninja RC1 error on install


I am trying to install the latest rc1 zip file on my host. After having unzipped all files in the root directory I cannot access the installer screen. I am getting the below error:

Warning: require(/www/wwwroot/mydomain/public/…/vendor/autoload.php): failed to open stream: No such file or directory in /www/wwwroot/billing.mydomain/public/index.php on line 26

Fatal error: require(): Failed opening required ‘/www/wwwroot/billing.mydomain/public/…/vendor/autoload.php’ (include_path=’.:’) in /www/wwwroot/billing.mydomain/public/index.php on line 26

Using Apache 2.4 and PHP 7.4

Thanks for any tips.


Can you please check that you downloaded the file called

Hi Hillel, you were right, I had downloaded the source file with the zip extension.

Ok one step further but not there yet :grinning:

I uploaded the correct file and was able to fill out all the fields on the setup page. Database connects, PDF is generated and email works fine.

However… once I click the submit button, the page just reloads and nothing happens. When I refresh my browser and I try to access the setup page again, I am getting an 500 server error.

Great, progress :slight_smile:

Are there any details about the error in storage/logs/

Hi again,

Great progress indeed… I found the following error in storage/logs:

[2020-11-19 17:03:16] production.INFO: The Process class relies on proc_open, which is not available on your PHP installation.

So I configured PHP to use proc_open and it worked!!! I was able to install Invoice Ninja.

After playing around a bit with the settings I ran into two more issues:

  1. Uploading a logo to my company settings gives me the following error:

500: Error: {
“message”: “Server Error”

  1. Generating a pdf file creates the following error: 500

In the error log I found the following 2 lines:

sh: npm: command not found
sh: node: command not found

I have found some other reports of these errors in the forum but am not sure how to go about solving this.

Do I need to install npm and node ? If so, what would be the best way to do this ? I am using Ubuntu 18.04

Thanks a lot,



  1. Try running php artisan storage:link

  2. npm/node are optional, you can use PhantomJS Cloud instead

Hi Hillel,

Here are the rest results based on your latest recommendations:

  1. when running php artisan storage: link I get:

In Filesystem.php line 315:

symlink() has been disabled for security reasons

Not sure what this means :neutral_face:

  1. I created a PhantomJS cloud account.

Following the V5 instructions I would need to edit the env file with the following information:


In my PhantomJS account I can only see my user name and an API key which doesn’t seem to be the same thing.

I guess this is above my current skill level at the moment so I will leave it here right now and revert back to V4.

A big thanks in any case for having been patient and helpful. I am sure I will give V5 another try in a few months time.

Kind regards,


Hi @jcsv75,

Looks like your host provided a disabled symlink(). That said there’s no much we can do regarding that.

When it comes to filling PhantomJS:
KEY is your API key and the secret is something that you define as double-step security.