Invoice Ninja behind Cloudflare

Hi,

I wish to hide my IP behind Cloudflare CDN.

I am also using stripe as a payment gateway. Do you have any know issues about such setup?

If yes, do you have any workaround?

I have just attempted a payment and after hitting pay I got an 500 error.

Thank you.

Hi,

If you can post details about the error from the logs we can try to help.

I’ve seen Cloudflare cause the PDF to not update but I’ve never seen a 500 from it.

https://invoiceninja.github.io/docs/self-host-troubleshooting/#pdfs-dont-appear-to-be-updating

I’m a heavy Cloudflare user and it’s cache causes problems with IN.

The solution is to create a page rule to prevent it caching the IN (sub)domain. Set the Cache Level to “Bypass”

1 Like

Thank you. That is exactly what I needed to know.

Sorry, it wasn’t the 500, but it was in the 500s class.
I was freaking out too much and didn’t take a note because the system was live and I had just sent a bunch of invoices.

@Danilo You’re most welcome.

Would you mind setting the subject of this thread to SOLVED so that others might benefit? :wink:

I am not sure if I am doing something wrong, but I have done it 16 hours ago.

@Danilo Have you tried logging into IN using the private window/incognito option of your favorite browser? If that works, it’s a local browser cache issue. If not, you’ll need to share a redacted image of the Cloudflare screen so that we can see how you set this up

HI, Bracckenhill,

It may be a misunderstanding. You solved the issue on your very first reply post. All good.

Thank you.