Invoice displays "glyph not found" character instead of Chinese characters

Hi, everyone!

It seems there is an issue with the display of characters. At least Chinese characters.

In InvoiceNinja interface:

In invoice:

Characters to copy-paste:

I checked in latest Chrome and Firefox — same result.
I tried to press “View PDF” button. I tried to clear browser cache.


@david any thoughts?

Which PDF generator are you using?

If you are using Snappdf, this would indicate your system is missing the chinese font packages, you’ll want to installs the fonts on the system, and then it should work as expected.

Yes, it’s Snappdf.

Ok, I’ll try to.

But don’t understand a few things.
It seems strange to me that:

  1. There is no problem in the InvoiceNinja interface. Why there is a problem in one place and not the other?
  2. You mean my Ubuntu 20.04 doesn’t have support for Chinese characters? Then I am back to the first point.

If non-standard characters (Chinese in my case) are stored in a database as Unicode symbols, then maybe Snappdf has problems decoding Unicode symbols? But it seems to me that Unicode symbols should be sent to the client “as is” and should be decoded on the client side? No? Maybe there is some processing by Snappdf? :thinking: :thinking: :thinking:

Do Chinese characters display correctly in PDF on the main InvoiceNinja app?

Chromium relies on the system fonts, the front end has its own set of fonts it uses. So once you install the system fonts, chromium will load the characters in the PDF normally.