Install of latest v4 results in blank page after setup

Hi There.

I am currently running v4.5.16 very happily. When either upgrading or doing totally clean install of latest v4 (4.5.46), I get a blank page after upgrade/setup.

There are no Apache errors nor Laravel errors (my storage/logs/* files are owned by the user running php).

I forced the incorrect DB password in the .env file - same result (ie. doesn’t look like it’s getting to even try DB connection).

I have done a totally fresh install with a new database - same result.

Please help - I’ve run out of things to try…
Web server: Apache2
Php version: 7.3 and tried 7.4 - same result.

Thanks in advance.
PS. - I’m wanting to upgrade to v5, but need to get to latest v4 first obviously.


A blank page may mean permissions issues, are there any errors in the web serve error logs?

There are zero errors in the Apache error log. If I do something random to force a http error, then I see it in the error log so I know the error log is working.

Nothing in the laravel log either (just done a fresh install and after getting the blank page, the log hasn’t even been created).

I have confirmed - PHP is running as the same user as what I extracted the Invoice Ninja zip file as - ie. the Web user owns 100% of the files in the docroot.

I’ve also checked the entire docroot’s permissions - every file and folder is 600 at least.


Not sure, without logs it’s hard to help.

@david any ideas?

Tx for trying - and agreed re the absence of logs…

Not sure if it helps to mention, but as soon as I restore the fines from the older version, everything works 100% again…

I’m getting a little desperate here…my host is turning PHP7.3 support off on the 16th November…

I’m thinking to switch to the SaaS version - am I able to sign up for as v4 account so that I can import my data to it and then uprade to v5?


The latest v4 version now supports PHP 7.4.

Sorry, the hosted v4 app no longer supports creating new accounts.