Install Invoice on Windows 10 step by step

Hello everybody,

I would like to install this beautifull invoice in my computer using XAMPP. I tried already to do this but unfortunately without success. It is there anybody which can help me in this process?

how I tried to install it:

  1. I downloaded the invoice zip file (zip). Also, I extracted the files from zip and I rename the folder invoiceninja
  2. I have placed the extracted folder in xampp\htdocs.
  3. I created the database and I named it same as the extracted folder “invoiceninja”
  4. I opened in browser the link localhost/invoiceninja and I received the error:
    Warning : require(D:\xampp\htdocs\invoiceninja\public/…/vendor/autoload.php): failed to open stream: No such file or directory in D:\xampp\htdocs\invoiceninja\public\index.php on line 26

Fatal error : require(): Failed opening required ‘D:\xampp\htdocs\invoiceninja\public/…/vendor/autoload.php’ (include_path=‘D:\xampp\php\PEAR’) in D:\xampp\htdocs\invoiceninja\public\index.php on line 26

Please help me step by step how I can install the invoice in my computer using XAMPP.

Thank you very much in advance!
Best regards,


  • Which version of the app are you installing, v4 or v5?

  • What is the name of the zip file you downloaded?

I would like to install V5.
The name of the zip file is: Release v5.0.25-release. Inside of the zip file is the folder with the name: invoiceninja-invoiceninja-dd2bd82.

I downloaded the zip file from

Thank you for your support!

Thanks, I think you downloaded the wrong file. You need to download (or use composer to install the vendor files).

I downloaded and I tried to install and when I open in browser localhost/invoiceninja there is 500 Server Error.

Thank you!

Are there any details about the error in storage/logs/


The error in storage/logs/laravel is: [2020-11-25 11:26:09] production.INFO: db fails

I tried to access also from brawser the link: http://localhost/invoiceninja/public/setup and the following error appear:

Oops, something doesn’t look right!

Make sure all requirements are satisfied.

Required extensions

mysqli :heavy_check_mark: gd :heavy_check_mark: curl :heavy_check_mark: zip :heavy_check_mark: gmp :x: openssl :heavy_check_mark: mbstring :heavy_check_mark: xml :heavy_check_mark: bcmath :heavy_check_mark: mysqlnd :heavy_check_mark:

PHP version

OK :heavy_check_mark:

Writable .env file

OK :heavy_check_mark:

Looks like gmp is missing?

I enable the extension openssl. When I try to open /localhost/invoiceninja it is the same: Error 500 server error. In log is the following error: [2020-11-25 11:53:40] production.INFO: db fails .

I enable also the GMP extension.

I tried to install the Invoice version v4.5.21. I opened in browser http://localhost/ninja/ and it works, then it appeared to me the INDEX with all Invoice ninja files:

[PARENTDIR] Parent Directory -
[ ] 2020-11-05 11:35 1.8K
[ ] Gruntfile.js 2020-11-05 11:35 1.2K
[ ] LICENSE 2020-11-05 11:35 2.4K
[DIR] app/ 2020-11-25 13:57 -
[ ] artisan 2020-11-05 11:35 1.6K
[DIR] bootstrap/ 2020-11-25 13:57 -
[ ] bower.json 2020-11-05 11:35 1.3K
[ ] codeception.yml 2020-11-05 11:35 646
[ ] composer.json 2020-11-05 11:35 5.1K
[ ] composer.lock 2020-11-05 11:35 483K
[DIR] config/ 2020-11-25 13:57 -
[DIR] database/ 2020-11-25 13:57 -
[DIR] docs/ 2020-11-25 13:57 -
[ ] gulpfile.js 2020-11-05 11:35 6.6K
[ ] package.json 2020-11-05 11:35 371
[ ] phpspec.yml 2020-11-05 11:35 87
[ ] phpunit.xml 2020-11-05 11:35 777
[DIR] public/ 2020-11-05 11:35 -
[DIR] resources/ 2020-11-25 13:57 -
[DIR] routes/ 2020-11-25 13:57 -
[TXT] server.php 2020-11-05 11:35 560
[DIR] tests/ 2020-11-25 13:57 -
[DIR] vendor/ 2020-11-25 13:58 -

I click on the public folder to start to install the Invoice. Then I completed the fields with necessary information:
Data base name,
user data base

then I point on install. After a few seconds the message appeared: Whoops, looks like something went wrong.

I have checked the the logs and there I found the error:
[2020-11-25 12:09:50] production.ERROR: ErrorException [0] : D:\xampp\htdocs\ninja\app\Models\Account.php [Line 1126] => Unparenthesized a ? b : c ?: d is deprecated. Use either (a ? b : c) ?: d or a ? b : (c ?: d) {“context”:“PHP”,“user_id”:0,“account_id”:0,“user_name”:"",“method”:“GET”,“user_agent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/86.0.4240.198 Safari/537.36”,“locale”:“en”,“ip”:"::1",“count”:3,“is_console”:“no”,“is_api”:“no”,“db_server”:“mysql”,“url”:"/"} []

Thank you for the error details, you need to change from PHP 7.4 to 7.3

I will try and I will get back to you.
Thank you for your support!


It’s working. Thank you for your support!

Best regards,

1 Like