Index file missing


I have Ninja Invoice installed in sub-domain which was working perfectly. Today I tried to use Cloudlflare on TLD & sub-domain (Ninja Invoice installation) but sub-domain didn’t work. So I reverted to my host. Now, my Ninja Invoice is returning 404 error. I tried to sort out with my host technicals but they said that ‘index’ file is missing from sub-domain which is true as I don’t see one there. I would appreciate if any of you could help me to restore my installation as I don’t want to reinstall for third time.

Thank you in advance.


Are you sure a file is missing? I’d suggest comparing your files against our codebase.

If you’re seeing a 404 it’s most likely an issue with the web server configuration.


Thank you for reply. I compared files on my server folder against codebase and can’t see any missing file. However, I’ve pasted here the error log for your reference. If you could help me further.

[Fri Mar 30 11:03:51.004043 2018] [autoindex:error] [pid 3371] [client] AH01276: Cannot serve directory /home/public_html/invoice/: No matching DirectoryIndex (index.html,Index.html,index.shtml,index.php,Index.php,index.phtml,Index.phtml,index.htm,Index.htm,default.htm,Default.htm,default.html,Default.html,home.htm,Home.htm) found, and server-generated directory index forbidden by Options directive,


Sorry, I’m not sure.

It seems your config is set to /home/public_html/invoice/, is this correct?
I recommend using this guide:
I have done a clean install, and used this guide to set it all up and it worked perfectly

Thank you all.

Well, the issue was entirely with .htaccess file which I restored from backup. The cause was redirect line ‘RedirectMatch 301 ^’ - missing from .htaccess file. But I’m wondering why and how the line was eliminated from file.