Importing to Self-Hosted and Invoice Template Issues

I tried out the online version, and, after adding a ton of products, decided it would be better for me to use the self-hosted version. I got it up and running, and everything seems to be working just fine, for the most part.

Firstly, a minor nitpick. The Ubuntu/Apache guide only mentions having to install the gd, curl, and mcrypt extensions to php5. They might want to add in that (at least in php7), composer will throw off errors if you don’t also add dom, zip, mbstring, and xml.

Anyway, everything’s up and running, and I exported the JSON file from the online version, which seems to contain everything I need. However, when I go to import into the self-hosted install, nothing gets updated. I checked my permissions, all the right directories are apache-writeable, mySQL has the permissions set appropriately, etc. but none of the items are being added. Write permissions are there, because manually added items persist across service restarts, reboots, etc. I turned on query logging and tried again, and it looks like it’s only passing a bunch of SELECT statements to the SQL server and that’s it. I fully admit I’m a complete neophyte with database issues, but doesn’t SELECT just locate items and not actually update/change/add them?

Granted, by this time I could have manually re-added everything, but I’d like to figure this out for future reference, at least.

My second question has to do with the invoice templates. It seems most of them are optimized for A4 sizes. When I change to US Letter, the formatting gets messed up. Essentially, any flourishes like boxes, background shading, etc. don’t take the changed page width into account, while the text seems to change just fine. This results in blank spaces where there previously weren’t any, and text running outside the box.

Is there any plan to make the templates more dynamic with regard to page size, or at least create templates on a per-size basis rather than designing for A4 only?

I’m not sure, are there any messages displayed after the import completes? If you want to email the JSON file to contact@invoiceninja.com we can try to replicate the problem.

We don’t have immediate plans to improve the templates when using alternate page sizes. If there are any major problems you want to fix we can try to help you resolve them by customizing the design.

No messages at all, unfortunately. It just reloads the Import/Export page. I sent the JSON file to you. Didn’t see anything in the Laravel error logs either, but I’ll be the first to admit I’m only partially aware of what I’d even be looking for.

Thanks, we’ll let you know what we find.

I think I may see the problem, the JSON import supports clients, invoices and payments whereas I believe you’re trying to import your product list.

You can use the CSV export and then import it but you’ll need to remove the first few lines with the ‘Products’ title.

I’ve just noticed we don’t support exporting the product list, we’ll make sure it’s added.

As a workaround you can create a CSV file by copy/pasting the contents of /products.