Imported data disappears after after importing an export from


I’m running a white label self hosted system (v5.5.103-SC113) on Debian 11 with one company set up. I have a white lable system running for my own business, I recently tried to import a JSON file for a second business from

The zip upload was successful, followed by notification of a successful import. I could log in and peruse the new company and its attendant data without issue, for a short while, then it all just disappeared. The company stays but all the data is gone. I’ve checked the database and it holds no data for the new company beyond the its basic info, all customers, invoices etc are gone.

I’ve tried the entire process from both the web app and the Windows app. Files uploaded via the Windows app appear correctly but it makes no difference with the JSON import, regardless of the upload mechanism the data loads, briefly, then vanishes.

I’ve tried delete/purge/artisan but none appear to make a difference.
I’ve tried uploading from App and Browser, same results.
I’ve tried upload csv’s individually and en mass, same results,

The logs show a successful import but nothing beyond that.

All help gratefully received.


@david any thoughts?

I haven’t seen this behaviour before. Are there any errors in the logs?

None that I’ve found so far. I increased the script times for php and that seems to have fixed it, in that data imported yesterday is still there today.

The import that finally stuck was done via the app using CSVs. All attempts at using a JSON import failed. Now I have it working, I’ll snapshot the VM and do some experimenting to see if I get the same results after reverting script times to their original setting.