Import / export - link < time out

not sure if something is wrong with my setup but when i generate export file ( settings > import/export) i receive an email with the link but when i try to access the link i get an error that site can not be reached/time out. # This site can’t be reached

this is the link that i received :

Port 8003 is not listening and i am not sure what service would be listening on this port. For troubleshooting i disabled my firewall & still no luck

CONTAINER ID   IMAGE                         COMMAND                  CREATED        STATUS         PORTS                                                  NAMES

874e2755bfb7 nginx “/docker-entrypoint.…” 28 hours ago Up 7 minutes>80/tcp, :::80->80/tcp dockerfiles_server_1
cd3b67253658 invoiceninja/invoiceninja:5 “docker-entrypoint s…” 28 hours ago Up 7 minutes 9000/tcp dockerfiles_app_1
04682429a5a2 mysql:5 “docker-entrypoint.s…” 28 hours ago Up 7 minutes 33060/tcp,>3306/tcp, :::3305->3306/tcp dockerfiles_db_1

my env file is set to port 8003, per instructions on github site

I changed (for testing and troubleshooting) this port to 80 and i was able to download it & link worked. But now sure what is proper setting for this port. Also, when the port was set to 80, my email function stopped working. So i am sure that broke something.

Any inputs how to address this?


Which version of the app are you using?

@david any thoughts?

Hi, its the latest. I upgraded it on Sunday. v 5.3.16

Are you using the standard docker-composer file or have you created your own?

It sounds like a docker configuration issue.

Hi david,
i am using standard docker-composer file that i downloaded from github,

I only modified few fields in env file as APP_URL, db username/password and mail settings.
What should be the port in APP_URL? 8003 or something else. Does this look right?


Are you modifying the env file in the docker project, or inside the container?

for reference, you should be modifying the docker env file.

I am modifying “env” file in docker files folder (docker project), not inside of container. The steps to the guide on github, it was very well written & easy to follow.

I just deployed Invoice Ninja on another host, and i have same experience. i used an IP instead of host name, just for testing. Everything else seems to work fine.

# IN application vars


Should I able to access via browser url ?

The storage folder should not be publicly accessible.

Thank you hillel,
why then generated backup link would include that port?

@david do you have any ideas?