How to control "Payment Received" auto email?


I’ve set up an automation with Zapier. And each time new invoice is created, the client receives “Payment Received” email automatically.

The payment is marked as PAID in the “Invoices” tab.

It happens immediately and we don’t get any payment in this moment. And the strange thing is that this changed from Sent, Partial, during the tests. But I didn’t change anything connected with email notifications. See attachment please

How to fix this?

Thank you!


There are options on Settings > Payment Settings to configure the email settings.

Hi Hillel,

I tried to use it with and without “Mark Paid Payment Email” checkbox, but with the same result.

Is there any other option I should consider?

I think I accidently put data from Zapier in “Amount Paid” field.

Ok, I think that would explain it.

1 Like