Hide documents customer invoice


I cannot seem to find the option to “hide” the documents on the portal when a customer looks at their invoice.

As example.

I register some hardware i purchase for a customer.
I create an invoice for a customer and put that specific hardware on the invoice

But constantly my original purchase invoice can be seen when they open an invoice in the portal, or click on the link in the email.

Is there a way to hide those documents? or at least not show them in the portal?


All invoice documents are visible to clients. Another approach may be to attach the documents to an expense and then invoice the expense, in the expense you can select whether or not the documents are included with the invoice.

im sorry that i did explain this clearly enough

i already register that as an expense.
i can see the checkbox to add the document to an invoice.
but what ever i choose, it always “re-checks” the box when i save the expense.
am i missing something here?

and thanks for the prompt reply, much appreciated

Sounds like it could be a bug

  • Are you selfhosting the app or using the hosted version
  • If selfhosting which version are you using
  • Does using a different browser make a difference

im indeed using a self hosted version white label.
let me get back on the browser check, and let me check if there are any updates i missed.

will report back asap. thanks again Hillel!


version Factuur gemaakt via Invoice Ninja - v4.5.19 | White labeled

Browser does not make a difference. Chrome / Edge / Firefox with no plugins enabled.
it keeps on re-checking the box as soon as i save my expense

do you know a way to permanantly turn this off by changing something in the database?
Strange is when i look at my mobile app, i can switch it on or off (but still shows it)