Help with ticket module

hello guys, i just came accross openninja, so far so good, id like to use it however i am using a turnkeylinux version 4.53, it runs fine, however i noticed there is a V5 released, so questions are:
1-whats is the major difference between legacy v4 and V5
2-is there any easy script installation to install V5 (so fair i tried on a cpanel webserver, download the zip file and uplod it to the root WWW. however when entering the address, it doesnt prompt for the installation)
3-how can i activate the ticket module on my V4, does the V5 comes with ticket module installed?
4-finally how to properly update V4 to the latest V4release (should i just upload the files into the root directory and overwrite?)
thats pretty much for now :slight_smile: thanks in advanced.


  1. We cover some of the differences in these videos:
    What's new in Invoice Ninja v5 - YouTube
    More new features in v5 - YouTube
  2. It should be available though Softaculous soon
  3. You need to use the develop branch of the code on GitHub
  4. To upgrade from v4 you need to install v5 as a separate app and then use the migration tool in the latest version of v4 on Settings > Account Management.

is there a known working method to install V5 from scracth on fresh ubuntu or debian, i rather have it on a container than a shared hosting webserver with cpanel ( backup purposes). I tried the guides on this forums someone posted but it didnt work. now when is going the ticket module be available on V5 without using the develop branch? . thanks

Sorry, as far as I’m aware the guides on the forum should work.

We aren’t able to provide ETAs for features.

the guides on the forum are for advanced users, i am not savy when i comes to linux, i know pretty much basic stuffs. but even in the thread you guys provide on the forums for installation guide, people struggling with the installation following up the guides. Anyways i tried to install it using the zip file (FTP) which prompted me for the setup, inserting all the requirements: db, email and pdf test, everything passes the test, but when i click submit for the installation to finish, it just get 404 No found, i spent a lot of hours tryng to get this to work, maybe tomorrow i can continue :smile: thanks for the help