Gmp, zip dependency PHP

I am trying to (finally) update to v5. I understand this will require first an upgrade to the latest v4, which I saw was recommended on a fresh install, then restore database.
I have created a fresh Ubuntu 20.04 VM, PHP 7.4, nginx
Installed ZIP for v4.5.50

When I access the site, I get error:
“Composer detected issues in your platform: Your Composer dependencies require the following PHP extensions to be installed: gmp, zip”

How do I proceed?


I suggest checking that the gmp and zip PHP extensions are enabled on your server.

Note: the latest version of v5 requires PHP 8.1.

will the latest v4 lso run on php 8 or does it need php 7.4?

The latest v4 currently requires 7.4

in case any other people need the solution - for v4.5.50, I installed php 7.4 and the commands to install these missing extensions were

apt install php-gmp
apt install php zip

1 Like