Getting Error 500 on Softaculous setup [sigh]

I keep getting this page after setup with Softaculous:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

More information about this error may be available in the server error log.
Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Plus there’s this redundant error log entry on my server:

[:error] [pid 515:tid 47685006599936] [client 198.98.57.136:45958] File does not exist: /home/admin/public_html/adminer.php

My domain manager has not been much help. I have installed similar platforms in the past without any hassle. I see lots of Error 500 topics listed here but never quite exactly the same issue. I thought mine was the classic newbie case.
Is there hope for me?

I’m not sure exactly what the issue is here, but what i can advise is the file is cannot locate, is not a file we use in Invoice Ninja.

Thank you for making that clear. Turns out I was reading the log entries in the wrong order. The entries that correspond to the same period as my install attempts are more of this genre:

[Sun Jan 22 15:51:22.288894 2023] [autoindex:error] [pid 28493:tid 47411796326144] [client 194.169.175.71:56068] AH01276: Cannot serve directory /home/adusr/public_html/.well-known/: No matching DirectoryIndex (index.php,index.php7,index.php5,index.perl,index.pl,index.plx,index.ppl,index.cgi,index.jsp,index.jp,index.phtml,index.shtml,index.xhtml,index.html,index.htm,index.js) found, and server-generated directory index forbidden by Options directive, referer: binance.com
[Sat Jan 21 21:44:41.197116 2023] [access_compat:error] [pid 4562:tid 47411775313664] [client 191.227.224.196:51756] AH01797: client denied by server configuration: /home/adusr/public_html/xmlrpc.php
[Sat Jan 21 03:39:37.863677 2023] [access_compat:error] [pid 4282:tid 47411802629888] [client 128.199.192.20:58883] AH01797: client denied by server configuration: /home/adusr/public_html/xmlrpc.php

I uninstalled and tried to reinstall again. This time I couldn’t get past the setup!

The following errors were found :
Required PHP extension not found : gmp

…says Softaculous without giving me a hint on how to resolve this.

I will greatly appreciate any sort of guidance!

From the error it looks like you need to enable the gmp PHP extension

I looked through the list of available PHP extensions (in cPanel) and couldn’t find with “GMP”.

Isn’t it odd that in a previous attempt I was able to go through with the installation without obstruction (resulting in an Error 500 page, mind you) and now the setup interrupts due to missing gmp extension?

@david do you have any ideas?

Is the gmp extension something that some (lower-grade?) web servers cannot handle and therefore made unavailable by some hosts?

@Benoit,

has the php version changed at all?

you should be able to add in the gmp extension in cPanel. I can’t think of any reason why they would disable access to it.

The first time I installed it I was advised to upgrade PHP version so I clicked “yes” and the setup went on. Then I uninstalled it (again with Softaculous) and tried to reinstall but got the gmp missing error.

Will I need to move to a new host if I want to run IN on my domain?

@Benoit

If your webhost is unable to provide support you may want to consider another host.

I actually asked them to install InvoiceNinja on my domain and the reply was (translated from French):

There is currently a problem with this software (InvoiceNinja) and our server environment. We have recently tried to set it up for another client which resulted with the software not functioning properly and the server itself losing performance.