Fatal Error after manual update

Since auto-update stopped working for me (see this topic) I tried the manual update from 5.6.18 to 5.6.23, but unfortunately that resulted in a Fatal Error. I then tried the same with 5.6.19, but again the Fatal Error occurred. Eventually I resorted to restoring a server backup from last night (via Siteground), but the Fatal Error persists. I have no idea what to do next and basically my site has been destroyed now.

Any ideas/tips?

The error that shows is this:

Fatal error: Uncaught Error: Failed opening required '/home/.../public_html/vendor/composer/../symfony/polyfill-mbstring/bootstrap.php' (include_path='.:/usr/local/php81/pear') in /home/.../public_html/vendor/composer/autoload_real.php:41 Stack trace: #0 /home/.../public_html/vendor/composer/autoload_real.php(45): {closure}('0e6d7bf4a5811bf...', '/home/customer/...') #1 /home/.../public_html/vendor/autoload.php(25): ComposerAutoloaderInit06f75d9bb671516440a93032a773a138::getLoader() #2 /home/.../public_html/public/index.php(26): require('/home/customer/...') #3 {main} thrown in /home/.../public_html/vendor/composer/autoload_real.php on line 41

And the strange thing is that the client portal is available without any problems, so the issue is related to admin only.


Have you tried manually copying over the release zip from here:

Hello Hillel,
That’s exactly what I have done. Leaving the .env file.

@david do you have any suggestions?

Oh and I discovered that both the mobile app and the desktop app are still functioning, although the latter also doesn’t take the update, so it’s purely the admin section of the self-hosted version (my website), which I prefer using over the desktop app.

Here is a screenshot of that Fatal Error, as the code in my initial ticket is not visible without scrolling:

Are you using the correct release file? it should be ~ 100mb or so. From the error, you may be downloading the smaller file which does not contain the vendor packages.

Hello David, I am using the invoiceninja.zip file as per this screenshot:

But upon checking the contents of the zip, the vendor/composer/ folder does not contain anything nearly the same as what the error says. So maybe the vendor folder is not complete in the zip file?

Just downloaded the .tar file, but same thing, the symphony folder is not visible in the vendor/composer folder:

@david @hillel

So what now? I cannot update, so have to remain forever on 5.6.18?

Have been waiting for a solution for almost two weeks now. InvoiceNinja keeps receiving updates, 5.6.30 already now, but I’m stuck on 18 and no solution from your side…

Time to look for another solutions then? again?


Have you tried manually copying over the latest release?

With all due respect @hillel, have you read any of what I wrote above?

I read all of it. The error looks like the problem may have been due to the contents of the zip which is why I’m asking if you’ve tried with the latest version.

No, I have not yet tried it with the latest version.

So basically what you’re saying is that the zip files in the Github Repo might be corrupted? That would be very handy!

Maybe instead of having your users being guinea pigs, you should make sure that the zip files you release are in fact not corrupted?

Downloaded latest .zip release (5.6.30) and now manually uploading finally works.

Can’t say I’m too impressed with this update process as it has taken more than two weeks to “solve” the issue and you guys have been releasing almost as many versions in that amount of days…