Expenses are automatically set to paid

Hi there,

using Version 5.8.20. When I create an expense it’s automatically set to paid, even if the global configuration is set to off.

Sorry for my bad English. I’m using the German translation and must improvise the correct language of Invoice Ninja.

Greetz!

Hi,

Which app are you using?

Flutter-webapp, if that’s the correct name.

Are you able to reproduce the issue using the demo: https://demo.invoiceninja.com

If you can post screenshots it may help me understand the problem better.

Interesting: In the demo the expense is just “logged”, in my system it’s marked as “Bezahlt” (paid).
Following first upload shows my tax-settings, because I must differetiate by normal VAT and lowered VAT (for food or drinks for example).

Can you post a screenshot of your settings on Settings > Expense Settings?

Hi, @hillel,

sure thing:

Oh, by the way: it’s getting a little bit weirder:

I imported bank-transactions by csv. So far so good. But when I created a new expense by a transaction and edited afterwards the label switches from “paid” to “pending” (“Ausstehend”).

I have the fear that I’m not yet firm enough with handling Invoice Ninja. But it seems that some German labels are not so intuitive yet – no offense, this software kicks ass!

I’m not sure, without steps to replicate it will be hard to help.

What version do you see in the about dialog?

Do you mean this? v5.8.20-C153

I can make screenshots in a few documenting my proceed.

If you can provide steps to reproduce this in the demo it would be most helpful.

Hi, and sorry for my late reply.

The steps are creating an expension. But now even repeating expenses are automatically set as “paid” even there’s has not been any transaction linked to it.

It’s weired and not good for having control over incomes and expenses.

Best greets!

Do you see the same problem in the React app?

There’s an option to switch between the apps at the top of the dashboard.

I’m going to answer as soon as I’ll have another expense.

By the way: The error does not exist in my testing-installation. What I’ve done now is to set the setting for automatically set any expense to paid and back. Maybe the setting was not correctly saved. We’ll see.

Oh look, within the React-app it’s working. Well, now I do not know if it’s because I used the React-app or it’s because I reset the expense-setting. With the next new expense I will try it within the Flutter-app and give you a feedback.

Best regards!

Well, here we go again.

I already had another expense I didn’t created, yet. Doing it with Flutter the error stil exists. I’m going to change and rechange the standard-settings for expenses within Flutter now.

Hello again,

the error still exists. Even when I turn off the standard-expenses-settings “paid” on, save, and off again.

Anything I can do for debugging? Are settings saved in the SQL-database?

Thanks

Not sure what to suggest, we need to be able to reproduce the error to be able to fix it.

I’m on the demo right now, and when I try to save a setting, an error accures: SMTP port must be a string. A bug?

Yes, that’s a separate bug which has been fixed in the latest release. I’ll make sure the demo is updated.

1 Like