Expense report not working after v5.3.45-W67 update

Hello team,

I just updated to 5.3.45 and everything works very well so far (the Windows app is rad and works perfectly on windows 11). My only problem is that, from all the reports, only the Expense report doesn’t work, I get a gray screen.

Steps taken

  • Updated straight from the app
  • PHP Artisan optimize
  • /update?secret=
  • PHP Artisan migrate (had to move one file for all the migrations to succeed because it says that the table already exists: 2021_08_25_093105_report_include_drafts_in_companies_table.php)
  • Rebooted the Droplet (I’m hosting at Digital Ocean on an NGINX droplet)
  • Tried web, mobile and desktop app
  • Deleted cache and cookies

What is really odd is that if I logout, I can go back to the Reports section, and i’m able to see all of them, except for the Expenses report.

Enabled debug mode and there’s nothing relevant, except for this which was happening before the update (fixed it by chown’ing the bootstrap/cache folder):

[2022-01-13 00:30:02] production.INFO: Performing Autobilling 2022-01-13 12:30:02
[2022-01-13 00:37:02] production.ERROR: Cannot update system because routes-v7.php is not writable {“userId”:1,“exception”:"[object] (App\Exceptions\FilePermissionsFailure(code: 0): Cannot update system because routes-v7.php is not writable at /usr/share/nginx/invoiceninja/app/Http/Controllers/SelfUpdateController.php:104)

I’m not sure what any other details I could provide, and I wish this could be fixed without a full reinstall. (Last one didn’t go very well :frowning: )

Thanks in advance,


Glad to hear it :grinning:

Can you please try loading the web app with ?build=profile at the end and then check the browser console for details about the error?

Of course, here it is (can’t upload the text log file):

Thanks in advance,

Thanks! That’s helpful but I haven’t been able to reproduce the error.

Do you know if the report worked initially? It could be a specific column which was added causing the issue. I believe you can clear the admin portal settings by setting company_user.settings to null in the database. If you try this maybe make a DB backup first.

If that doesn’t help if you want to send an email to contact@invoiceninja.com I can try to debug the issue with you.

Worth noting we just deployed a new version of the app to the Windows store which could help.

Thanks Hillel!

I updated the app; no luck. I’ll try with the database change and let you know.

Hello Hillel,

Issue fixed by setting company_user.settings table to NULL in the database. I’ll report back if this breaks anything, but doesn’t seems so.

for completeness sake, here’s the mysql command executed for that change:

use [your database];
update company_user set settings = NULL where id = 1;

Thanks! If that’s the case the problem is likely from adding a specific field to the report, please let us know if you track down which field it is.