Error after updating to 4.2.0

Hi -

I just updated to 4.2.0 version. Everything looks good but clients. When I try to view someone, i have the “Whoops, looks like something went wrong.” error message on the /public/clients/## page.

I tried with public/update with no success. Can you help me with this?


Are there any details about the error in storage/logs/laravel-error.log

Thank you Hillel for your quick response.

I just cleared the laravel-error.log file and noticed that the problem disappear. I do not know why or how, but there is no error anymore.

Case closed. Thank you again.


Great to hear, thanks for letting us know!


Something went wrong again. I have the same initial issue…

This is what laravel-error.log says:

[2018-02-25 16:39:25] production.ERROR: ErrorException [0] : /storage/framework/views/4bf5750952a98fa12d5657785e1b823d3e43a5a8.php [Line 141] => Trying to get property of non-object (View: /resources/views/clients/show.blade.php) {“context”:“PHP”,“user_id”:1,“account_id”:1,“user_name”:“XXXXXXX”,“method”:“GET”,“url”:“https://www.XXXXXXX/public/clients/17",“previous”:“https://XXXXXXX/public/clients”,“user_agent”:"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.167 Safari/537.36”,“ip”:“”,“count”:1,“is_console”:“no”,“is_api”:“no”,“db_server”:“mysql”} []

I removed sensible information.

Can you help me with this?


Have you tried loading /update


No success…

Any ideas?

If you have command line access it may help to run php artisan view:clear

What do you see on line 141 of /storage/framework/views/4bf5750952a98fa12d5657785e1b823d3e43a5a8.php

Thanks for your quick response Hillel -

When I try with command line php artisian view:clean, I get: Could not open input file: artisan.

Line 141 of /storage/framework/views/4bf5750952a98fa12d5657785e1b823d3e43a5a8.php is:

<?php echo e($client->size->name); ?><br/>

Thanks for your help…

Thanks, looks like a bug.

Setting the client’s size may help, we’ll work on a fix…

Here’s the fix, we’ll include it with our next release.

It looks like the error occurs if the client has the ‘industry’ set and the ‘size’ left blank.


It worked perfectly.

Thank you.

I to had this issue… Was about to report it and seen this post…

The fix took care of it…

Thank you Great program…