Error 500 on invoice email and client portal after update to v5.5.113-C115

After I updated to v5.5.113-C115 (without errors shown during update), now I can’t send email any invoices. It shows error 500 whenever I press send to email an invoice.
I can email statements without issue, but emailing invoices is broken.

Attaching the error that shows in the log for this.
Please help as it the fix is urgently needed to be able to send invoices again.
For security, in the attached log I replaced my actual domain with “

production.ERROR: Undefined property: stdClass::$enable_e_invoice {"userId":1,"exception":"[object] (ErrorException(code: 0): Undefined property: stdClass::$enable_e_invoice at /home/webserver/

Invoiceninja error when emailing invoice.txt (15.5 KB)

Update - when client clicks on an invoice it also is giving error 500 in the client portal.

I ran composer update as some other threads suggested, no difference.

@david @hillel
I still can’t fix it


If you go to settings and click Save, does the issue resolve for you?

Unfortunately it didn’t solve the problem


Can you try restarting the queue’s with

php artisan queue:restart

I did that
No change


I’ve tagged a new release, can you try upgrading.

It’s not showing me any update notification yet

Also (you probably already noticed) - I just saw that in the dashboard activity log, even though I pressed send to email invoice to the client’s email it is showing sent to NULL NULL (tried emailing a test invoice to test client below, and the client did have an actual email set which wasn’t NULL):

Screenshot 2023-05-03 231049

How to make the self-updater show the ‘update available’ notification ? I originally installed invoiceninja with Softaculous and it’s not showing me a newer available version yet as it usually does

We specifically disable the self updater on Softaculous installations. They are not designed to use the updater and should be managed exclusively through Softaculous

All the updates I did so far the last 2 years were through the self updater. Softaculous doesn’t detect any new updates for invoiceninja in my case. How do I update

After waiting a day the update notification finally appeared and after the update, the errors are gone. Thanks

1 Like