Error 500 after new installtion on shared hosting

Hello
After 10 hours of reading and try to locate the issue, I hope some of you can help me.

I have few issues. I can’t add a quote or generate a PDF without get a Error500, internal server error.

After talking with the shared hosting provider and adjusting the settings for proc_open, exec etc for my domain. I have one error left in the log file. See below.

[2021-09-14 10:25:10] production.ERROR: file_get_contents(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 {“userId”:1,“exception”:"[object] (ErrorException(code: 0): file_get_contents(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 at /home/…

If I have a look in my php.ini, allow_url_fopen is ON

Has anybody an idea where the issue could be?

I use shared hosting at Altushost, Multi PHP 7.4.22, for installation I used Softaculous.

I updated to version 5.3.0 C59. The heathcheck looks fine. Everything is green.

I also can’t send an email. I tried two different webmailer including gmail. No change.

Here the SOLUTION:
The hoster enabled PHP parameter “allow_url_include”

I think you need to enable allow_url_fopen

I think the same. I checked the php.ini and it shows ON.
I tried to switch it off and on again. No change. It shows ON and the error log shows OFF.
Any ideas?

@david do you have any suggestions?

I had this same issue on my shared host account. i have to escalate to the webhost - they need to do something behind the scenes to make this work.

You may also want to try adding

LOCAL_DOWNLOAD=true

into your .env file, this may bypass this function

Hi, Thanks for the idea. I asked the webhoster and they did something. PDF works at least. Email is still a problem.

There should be more info in the logs

First time that I got an email failure in dashboard/sys log. Tried 20 times without any failure message.
In the lavarel.log file is nothing. In the sys_log table I can see that the connection fails.

“Connection could not be established with host mail.domain.com :stream_socket_client(): unable to connect to ssl://mail.domain.com:465 (Connection refused)”

I tried every setting. The same setting I have now works in every email client, I use.

I am out of ideas.

who is your mail host?

All inkl. in Germany
https://all-inkl.com/wichtig/anleitungen/kas/e-mail/mail-adresse-autoresponder-weiterleitung/e-mail-konto-anlegen_98.html

I tried with my gmail account again. Email fault looks like this:
“Connection could not be established with host smtp.gmail.com :stream_socket_client(): unable to connect to tcp://smtp.gmail.com:587 (Network is unreachable)”

I would ask your webhost for help on this, it says network unreachable. i am assuming you are using TLS for encryption?

Yes. Same fault with SSL and port 465. I will ask the web hoster. Thanks.

Wow. My hosting provider changed few setting and it works.
Thanks for the time and responses.
I will definitely provide my clients with Invoice Ninja solution. Great work!

1 Like